Transaction Slowdown
Incident Report for Classy
Resolved
This incident has been resolved.
Posted Nov 09, 2022 - 11:08 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 09, 2022 - 09:18 PST
Investigating
We are investigating an issue regarding slow donations.
Posted Nov 09, 2022 - 08:08 PST
This incident affected: Classy (Campaign & Fundraising Pages).