Latest version of Chrome browser impacting page load for Chrome users
Incident Report for Classy
Resolved
The identified issue with the latest version of the Chrome browser has been addressed for Classy users and we are once again seeing successful transactions on Chrome 117 browsers. A very small subset of users who chose the option to upgrade to the updated Chrome version on desktop-only experienced page load issues on Classy as well as many other websites.
Posted Sep 13, 2023 - 10:40 PDT
Identified
We have identified an issue with the latest version of the Chrome browser that is impacting page load. This is not impacting other browsers or other versions of Chrome.
Posted Sep 13, 2023 - 08:35 PDT
Investigating
Currently investigating an issue with the latest version of the Chrome browser that is impacting page load. This is not impacting other browsers or other versions of Chrome.
Posted Sep 13, 2023 - 08:14 PDT
This incident affected: Classy (Campaign & Fundraising Pages, Classy Manager).