Incorrect Currency Showing on Donation Pages
Incident Report for Classy
Resolved
We identified an issue with our currency service fetching current exchange rates, causing it to error and display an incorrect currency for certain single-currency campaigns and donation pages. We implemented a fix around 8:43 AM, and are seeing correct currencies display.
Posted Jan 17, 2022 - 09:07 PST
Investigating
We are investigating an issue involving an incorrect currency appearing on donation pages.
Posted Jan 17, 2022 - 08:11 PST