Mismatched SSL certificate on email links
Incident Report for Classy
Resolved
This incident has been resolved.
Posted Jun 09, 2021 - 12:17 PDT
Identified
A 3rd party email provider is serving a mismatched SSL certificate for our email links which shows as a warning in the browser when clicked. We are working with the provider to get this resolved. We apologize for the inconvenience.
Posted Jun 07, 2021 - 09:06 PDT